Login required to started new threads

Login required to post replies

Problem with zipp valve extender
Quote | Reply
Im using the valve extender that comes with my zipp 404s. At first, the air keep leaking when I use the pump.. So I put teflon tape and made the seal good, and now I can pump the tube ONLY when I start with very low PSI (like 20 psi).

So for example, If I pump a tube, I have to first let most the air out, and then I can start pumping to any desired PSI .. Then I remove the pump head... Lets say the next day, I want to pump the tube back to 115 psi.. I have to take the air back down to 20PSI in order to pump. If I dont do that, the air just wont go in..

Anyone have this same problem? Any fixes or am I doing something wrong.
Quote Reply
Re: Problem with zipp valve extender [125mph] [ In reply to ]
Quote | Reply
if you're using 404's save yourself the headache of using valve extenders in the first place and just buy tubes with 80mm valves and then you'll never have to worry about it.

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
Michael in Fresno
"Do you spend time with your family? Good. Because a man that doesn't spend time with his family can never be a real man" V. Corleone
Quote Reply
Re: Problem with zipp valve extender [125mph] [ In reply to ]
Quote | Reply
I don't care for those extenders. Actually, I think they suck. You can either buy tubes with the 80mm valves (can be pricey), or get a decent set of extenders where you remove the valve core of a standare 48mm tube.
Quote Reply
Re: Problem with zipp valve extender [125mph] [ In reply to ]
Quote | Reply
Lock out the valve core fully open. Teflon tape. Good. To. Go.

Worst case, save yourself the trouble & get a Topeak/Vittoria extender with external valve core, eliminates the issue.
Quote Reply
Re: Problem with zipp valve extender [Tribato] [ In reply to ]
Quote | Reply
Tribato wrote:
if you're using 404's save yourself the headache of using valve extenders in the first place and just buy tubes with 80mm valves and then you'll never have to worry about it.


WHAT? That might cost.....shit man.....$16.00! Damn Bro, he just spent a thousand or two on wheels and now you want him to spend SIXTEEN DOLLARS on tubes? /pink

----------------------------------------------------------

What if the Hokey Pokey is what it is all about?
Quote Reply
Re: Problem with zipp valve extender [Record10Carbon] [ In reply to ]
Quote | Reply
I HATE HATE HATE valve extenders.
did I say I hate them???

just buy the 80mm tubes.

_________________________________________
What if I fall? Oh but my darling, what if you fly?
Quote Reply
Re: Problem with zipp valve extender [125mph] [ In reply to ]
Quote | Reply
The ones with the internal valve core are trash. Switch to the integrated ones from Zipp/Vittoria/Topeak (need tubes that you can remove the valve core --> conti/qtubes are good)

I've never had a problem with these: http://zipp.com/.../detail.php?ID=16716
Quote Reply
Re: Problem with zipp valve extender [125mph] [ In reply to ]
Quote | Reply
125mph wrote:
Im using the valve extender that comes with my zipp 404s. At first, the air keep leaking when I use the pump.. So I put teflon tape and made the seal good, and now I can pump the tube ONLY when I start with very low PSI (like 20 psi).

So for example, If I pump a tube, I have to first let most the air out, and then I can start pumping to any desired PSI .. Then I remove the pump head... Lets say the next day, I want to pump the tube back to 115 psi.. I have to take the air back down to 20PSI in order to pump. If I dont do that, the air just wont go in..

Anyone have this same problem? Any fixes or am I doing something wrong.

I gave up using valve extenders on my 404's, I don't care how good it looks, it just isn't worth the hassle. Buy 80mm valve tires, trust me the extra $$ for the longer valves is worth it!!

Now, I have to use valve extenders on my 808, but I only use it when I'm racing.



"Though she be but little, she is fierce" ~Shakespeare | Powered by HD Coaching | 2014 Wattie Ink Triathlon Team | Facebook | Instagram | Twitter
Quote Reply
Re: Problem with zipp valve extender [KyraMorgan] [ In reply to ]
Quote | Reply
KyraMorgan wrote:
125mph wrote:
Im using the valve extender that comes with my zipp 404s. At first, the air keep leaking when I use the pump.. So I put teflon tape and made the seal good, and now I can pump the tube ONLY when I start with very low PSI (like 20 psi).

So for example, If I pump a tube, I have to first let most the air out, and then I can start pumping to any desired PSI .. Then I remove the pump head... Lets say the next day, I want to pump the tube back to 115 psi.. I have to take the air back down to 20PSI in order to pump. If I dont do that, the air just wont go in..

Anyone have this same problem? Any fixes or am I doing something wrong.


I gave up using valve extenders on my 404's, I don't care how good it looks, it just isn't worth the hassle. Buy 80mm valve tires, trust me the extra $$ for the longer valves is worth it!!

Now, I have to use valve extenders on my 808, but I only use it when I'm racing.

Cool, I'll get the 80mm valves. I dont care about the extra few dollars.. I thought it wasnt good for the tubes or something.
Quote Reply