Login required to started new threads

Login required to post replies

Garmin HRM is paired, but gives no reading
Quote | Reply
Was on the bike with all things being normal today, but was getting no data in the HRM field on my 520.

Tried the usual "disconnect/reconnect" that I occasionally have to do, but no dice.

Removed it, and it wouldn't pair again.

Put in a new battery, and was able to pair again.

Still gives no reading. Gave one for just a few seconds, but that was it.

My 310 also connects to the strap, but gives no reading.

Any ideas?
Quote Reply
Re: Garmin HRM is paired, but gives no reading [greenlawnracing] [ In reply to ]
Quote | Reply
Is it one of the soft-strap ones with the snap-on pods? If so, it could be that the pod is fine but the strap itself is knackered, which is very common, especially amongst the older soft-straps; it will connect to a device but not give any data because the strap can't read anything intelligible from your body.

I would try:

(1) Wetting the strap - give it the best possible chance of being able to read something.
(2) Washing the strap - might resurrect it but possibly only a temporary fix.
(3) Replace the strap - pick up a new one on eBay or similar, preferably one of the newer ones with the black plastic diagonal "stripes" as IME these are much more durable.
Quote Reply
Re: Garmin HRM is paired, but gives no reading [greenlawnracing] [ In reply to ]
Quote | Reply
I have recently gone through 2 straps and 2 pods. They either don't read and read 50-60 beats too high. Sometimes i can get one of the combos to work before I workout but Garmin HRM straps suck. I have tried getting them wet but doesn't work for me. I am looking for alternatives
Quote Reply
Re: Garmin HRM is paired, but gives no reading [timr] [ In reply to ]
Quote | Reply
The higher heart beat could be contributed to the clothes you are wearing. I notice that on some of my tech tees will create a friction electrical interference causing the pod to report high numbers, unless I get a good sweat on that keeps the shirt from rubbing against the pod. This doesn't help with the OP's issues.
Quote Reply
Re: Garmin HRM is paired, but gives no reading [greenlawnracing] [ In reply to ]
Quote | Reply
Take the strap and carefully clean it with fresh water. Then wash the snap connectors with soapy water and a q-tip. Then carefully take both the strap and pod and throw them in the trash and get one from Wahoo instead.

----------------------------------------------------------
Zen and the Art of Triathlon. Strava Workout Log
Interviews with Chris McCormack, Helle Frederikson, Angela Naeth, and many more.
http://www.zentriathlon.com
Last edited by: ZenTriBrett: Apr 16, 18 9:32
Quote Reply
Re: Garmin HRM is paired, but gives no reading [ZenTriBrett] [ In reply to ]
Quote | Reply
Here is where it gets really weird.

I can get both my current HRM and my old one to connect to both my 520 and rarely used 310.

But neither will give a reading.

Both popped on for just a split second, but that was it.

Will call Garmin in the AM unless anyone has any ideas.
Quote Reply
Re: Garmin HRM is paired, but gives no reading [greenlawnracing] [ In reply to ]
Quote | Reply
You are dead
Quote Reply
Re: Garmin HRM is paired, but gives no reading [JoeO] [ In reply to ]
Quote | Reply
Funny you mention that. My wife (a nurse) said "is your watch reading a heart rate"?

I said "yes. Yes I'm alive."
Quote Reply
Re: Garmin HRM is paired, but gives no reading [greenlawnracing] [ In reply to ]
Quote | Reply
Can't get to the pic anymore but there was joke when I had my heart attack was ... Oh thank god it wasn't my garmin
Quote Reply
Re: Garmin HRM is paired, but gives no reading [mclousing] [ In reply to ]
Quote | Reply
Garmin said I likely had a bad strap. A bit odd that its two of them, but they are sending me one regardless.

They did say the fact that it is pairing to my power meter and trainer lead them to believe it is receiving ANT + just fine.

My crank and trainer broadcast ANT + and BLE. For some reason I was under the impression that the 520 used BLE - does it not? Google leads me to believe perhaps I misread the original review, and the BLE is only for phone alerts.
Quote Reply