Login required to started new threads

Login required to post replies

Di2 Help!
Quote | Reply
Ok, I'm going to start of by saying that I am currently stationed in India where there are no bike shops capable of working on electronic components. So seeking a certified mechanic is not an option.

Because I am in India I primarily ride using Zwift and Trainer road (TR). I spent a long period of time using TR and didn't shift or think to charge my Di2. When I went back to Zwift my Di2 was dead. When I went to charge it I got nothing. The charging unit is not even giving any lights (internal battery charger). When plugged into the computer with the charger I am able to connect to the system with E-Tube but it cannot find the battery.

Assuming the battery was dead I ordered a new battery. It just came in and I plugged it in. Everything seemed to work fine for about 15 minutes until everything went dead again with the same issues.

The charger doesn't seem to be the problem as it will connect to the computer and detect all the shifters and derailleurs but I ordered another one just in case.

I'm at a complete loss on where to go with this. Does anyone know if this is a common issue or what other troubleshooting I can do?
Quote Reply
Re: Di2 Help! [ptbashor] [ In reply to ]
Quote | Reply
Are you trying to charge it through the usb on the computer? I think you may have to plug it into an electrical outlet to charge it.
Quote Reply
Re: Di2 Help! [ptbashor] [ In reply to ]
Quote | Reply
Which product code is the battery?
Did you do a firmware update when you received it?


Connect - Velogic Fit l Facebook l Twitter
Or - Speedtheory l Facebook l Twitter
Quote Reply
Re: Di2 Help! [ptbashor] [ In reply to ]
Quote | Reply
Go through all of your connections. If there is some kind of short in the system, it would drain (and eventually over discharge) the battery, and might be doing the same to the new one.
Quote Reply
Re: Di2 Help! [ptbashor] [ In reply to ]
Quote | Reply
Also check the connections to the derailleurs to make sure they aren't just connected but will snap also. you could have it plugged in and then when you move it or bump it they still appear to be plugged in but don't get power. When putting my bike back together the first time I traveled with Di2 i discovered this on the battery which caused the whole system to not work even though I thought it was plugged in it still needed to snap, then again after that I bumped a cable going to the rear derailleur and it didn't work until I checked the connection and heard/felt the snap

---
You'e opinion is only as good as your signature line
-Chris
Quote Reply
Re: Di2 Help! [ptbashor] [ In reply to ]
Quote | Reply
When you plug your Di2 into the computer, make sure to update all firmware, that should solve the issue.
Quote Reply
Re: Di2 Help! [cyclenutnz] [ In reply to ]
Quote | Reply
Old Battery is: 72LOJW11838
New Battery is: 72LQCK13442

I've plugged it into the computer and the firmware appears to be up to date, however, it doesn't recognize the new battery or the old battery.

I've tried charging it by the computer and multiple outlets without any luck. I am also not getting any lights on the charger which makes me suspect that the charger might be bad, although, I can connect to the computer and e-tube finds everything except the battery.

It's possible that I'm getting a short. I'll go through and check the wires today.
Last edited by: ptbashor: Dec 12, 18 21:12
Quote Reply
Re: Di2 Help! [ptbashor] [ In reply to ]
Quote | Reply
ptbashor wrote:
Old Battery is: 72LOJW11838
New Battery is: 72LQCK13442

I've plugged it into the computer and the firmware appears to be up to date, however, it doesn't recognize the new battery or the old battery.

I've tried charging it by the computer and multiple outlets without any luck. I am also not getting any lights on the charger which makes me suspect that the charger might be bad, although, I can connect to the computer and e-tube finds everything except the battery.

It's possible that I'm getting a short. I'll go through and check the wires today.

Do you have an extra e-tube wire? This would allow you to connect the battery directly to one of the 5 junction A ports to see if the charger and e-tube software can find it.

Alternatively you could temporarily move the junction A to the battery e-tube cable coming out of the seat tube, connect the charger and see if the e- tube software can find the derailleurs which should confirm that the battery e-tube wire and junction B/connection are functioning properly.
Quote Reply
Re: Di2 Help! [ptbashor] [ In reply to ]
Quote | Reply
Thank you everyone for your help.

I isolated the battery cable from junction A and after unplugging and re-seating everything it seems to have solved the problem.
Quote Reply