Login required to started new threads

Login required to post replies

Computrainer - Calibration Error
Quote | Reply
I hadn't used my Computrainer in a few weeks and the unit died while I was prepping to get on the bike. An electronic technician said that I had "soft blown" the fuse in the power supply and it was replaced.

The unit now turns on but I cannot calibrate the Computrainer or control the unit either in ERG mode or through PerfPro. I keep getting an error of 99.99 when I try to to do the roll down calibration.

I have looked at a few different forums and some individuals suggest the problem is the DIN cable while others have suggested that there is a problem with the load generator.

Does anyone have any ideas, insights or suggestions?

Don't really want to buy a new trainer if I don't have to!

Thanks in advance.
Last edited by: cmck: Aug 29, 20 18:24
Quote Reply
Re: Computrainer - Calibration Error [cmck] [ In reply to ]
Quote | Reply
Try a new din cable first, as they’re cheap and readily available on Amazon. If this doesn’t work, PM me as I’ve a number of spare load generators and head units.
Quote Reply
Re: Computrainer - Calibration Error [null-and-void] [ In reply to ]
Quote | Reply
I would agree that swapping cables is the best and cheapest first steps, and not a waste of money if you find another fix. Do you have any friends living near you with a CT. Swapping out the Load Generator and then the Control Unit would also be worthwhile. When you run in the ERG mode are you using the PC software or running it from the Control Unit. If you have to tried running ERG from the control unit it would be worth a go. If that worked then the problem is most likely in wire to the PC or the PC software.

Sb
Quote Reply
Re: Computrainer - Calibration Error [luath] [ In reply to ]
Quote | Reply
Thanks for the replies!

Will order a DIN cable online as a starting point.

All my cycling friends have moved away from Computrainers so don't have the ability to swap out parts as a test.

I have tried to run the Computrainer with just the controller and then as a separate step, from the PC, to no avail. I also tried running the Computrainer from my power meter via PerfPro but the resistance does not change when I run a workout.
Quote Reply
Re: Computrainer - Calibration Error [cmck] [ In reply to ]
Quote | Reply
There's still a lot to be said for Computrainer and it's a shame that they faded away. Interestingly enough, the newest Kickr has a data port for future ethernet connectivity, so wires turn out not to be such a bad thing ;)

If your DIN cable is bad, PerfPro won't be able to control your load generator via your power meter. If you're able to launch PerfPro, then your stereo cable and FTDI adapter are good, as PerfPro would give you a port error when you try to launch Studio. So, I suspect that the problem likely is the DIN cable, esp as you can't control the load generator via the head unit.

Good luck in your troubleshooting!
Quote Reply
Re: Computrainer - Calibration Error [null-and-void] [ In reply to ]
Quote | Reply
Well I replaced the DIN cable and I have good news and bad news.

The good news...is the roll down calibration is working again.

The bad news...is the resistance doesn't change either by manually using just the Computrainer controller or by trying to run the Computrainer via PerPro. PerfPro tells me the Computrainer isn't responding.

Thanks for the advice. Replacing the DIN cable was a cheap test option.
Quote Reply
Re: Computrainer - Calibration Error [cmck] [ In reply to ]
Quote | Reply
Just in follow up...

It turned out that the power supply, load generator and DIN cable were all damaged. It looks like one of those components shorted and damaged everything else. I did not test the controller just in case it was the culprit and I did not want to take a chance and damage the new components. The electronics tech figures as the power supply damage was a slow blown fuse it is more indicative of an "upstream" short or component failure. The power supply was plugged into a MONSTER surge protector so very unlikely that the damage was due to a power surge.
Quote Reply
Re: Computrainer - Calibration Error [cmck] [ In reply to ]
Quote | Reply
I have a slightly different calibration error. In the calibration screen, it flashes the last speed (25.33), and then reads 0.00 and 2.00. Speed won't roll up when you start pedaling and can't reset. Is this the head unit, cable or load generator?
Quote Reply
Re: Computrainer - Calibration Error [tswitz1234] [ In reply to ]
Quote | Reply
Try DIN cable first, then head unit, and then generator, in that order.
Quote Reply
Re: Computrainer - Calibration Error [null-and-void] [ In reply to ]
Quote | Reply
DIN cables are cheap and they are readily available on Amazon. I could not find any local electronic stores or even commercial electronic distributors that still carry DIN cables. DIN appears to be an older connection standard and there are different types - just make sure you get the right type of DIN connector for the Computrainer.

A new DIN cable solved my roll down calibration issue but unfortunately I had other components that were also damaged which prevented the resistance from changing.

I have talked to other current and former Computrainer users and the DIN cable replacement was a good first step.
Last edited by: cmck: Nov 15, 20 17:41
Quote Reply
Re: Computrainer - Calibration Error [cmck] [ In reply to ]
Quote | Reply
OK, the DIN cable didn't fix it. Does anyone have an extra control unit they're willing to part with?
Quote Reply