Login required to started new threads

Login required to post replies

Prev Next
Re: Official PowerTap Thread [David_Tris] [ In reply to ]
Quote | Reply
I love my P1 pedals, nearly two years old now. But you have to wonder when v2 will be out. Especially with Garmin releasing the Vectors in such a smaller form than the P1 pedals are.

A wise man once told me " you're here for a good time, not a long time"

How right he was!!
Quote Reply
Official PowerTap Thread [ In reply to ]
Quote | Reply
Since the last update my P1 have turned into complete bullshit! Nothing works on it, whether it'd be on BLE or ant+ on trainer road with my Samsung galaxy Tab A tablet or garmin F3, 520 nor 1000... it just reads like straight doodo!!!

The last time I spoke to a rep they tried to say that it was a garmin issue and not a pedal problem however my HR is consistent with what my tablet and all 3 other garmin devices read!!!

I should've never done the last update as I am still getting the "missing right pedal" message even during rides!!! I'm so fucking pissed with this last firmware I swear, it makes me seriously fucking P-I-S-S-E-D O-F-F!!!

Speed kills unless you have speed skills!!!
Last edited by: playero: Jun 4, 18 4:11
Quote Reply
Re: Official PowerTap Thread [playero] [ In reply to ]
Quote | Reply
Still getting "missing right pedal" warning, after last firmware update.
Quote Reply
Re: Official PowerTap Thread [Ksavostin] [ In reply to ]
Quote | Reply
I spoke to the powertap service rep and be said that's a garmin issue and not a Powertap problem.

Has anyone received their v3 battery caps and noticed any improvements on power spikes/drop offs and overall consistency???

Speed kills unless you have speed skills!!!
Quote Reply
Re: Official PowerTap Thread [jbartholomew] [ In reply to ]
Quote | Reply
was getting short (few seconds) power/cadence drops on 2014 G3 hub on HED belgium. replaced the battery. seemed to work fine for a few rides. now the power/cadence drops are up to 40 seconds. using with a 2013 910XT Garmin watch.

any recommendations?
Quote Reply
Re: Official PowerTap Thread [jbartholomew] [ In reply to ]
Quote | Reply
I'm having trouble with my Powertap GS and it's driving me nuts.

A few weeks ago, it died during a ride. OK, no prob. I replaced the battery, but 5 mins into my next ride, my Garmin told me the battery was low, then power readings were gone.

Since then, I have replaced 3 batteries and I get the same reading every time. 5 mins of power, then I get the same notice, then it dies.

So, I removed the pm, updated the firmware, cleaned off all the contact points, ensured the o ring is properly seated, but nothing works. It dies after 5 mins every time.

I also tried multiple devices and apps, to include trainerroad (PC), Garmin (watch), and even the strava app (phone) and they all read it. They also all pick up my HR monitor, cadence sensor, etc...

I will contact Saris today, but if you guys have any suggestions, pls let me know.
Quote Reply
Re: Official PowerTap Thread [d00d] [ In reply to ]
Quote | Reply
d00d wrote:
I'm having trouble with my Powertap GS and it's driving me nuts.

A few weeks ago, it died during a ride. OK, no prob. I replaced the battery, but 5 mins into my next ride, my Garmin told me the battery was low, then power readings were gone.

Since then, I have replaced 3 batteries and I get the same reading every time. 5 mins of power, then I get the same notice, then it dies.

So, I removed the pm, updated the firmware, cleaned off all the contact points, ensured the o ring is properly seated, but nothing works. It dies after 5 mins every time.

I also tried multiple devices and apps, to include trainerroad (PC), Garmin (watch), and even the strava app (phone) and they all read it. They also all pick up my HR monitor, cadence sensor, etc...

I will contact Saris today, but if you guys have any suggestions, pls let me know.

Please let me know how you go on - could be coincidence but I have a similar issue on a GS ...

On another note, does anyone know the led flashing functions / messages from the led inside the power cap ?

WD :-)
Quote Reply
Re: Official PowerTap Thread [PowerTapPM] [ In reply to ]
Quote | Reply
I have a powertap c1 unit. A couple of months ago I was losing connectivity after a few minutes of riding. I would pull the battery, it would connect OK, then dropout again. Replaced the battery, but still had the same issue. Powertap support indicated it was likely moisture shorting the electronics.

I took off the battery and electronics cover and did find evidence of moisture. I dried the unit out and everything seemed to be working ok for the past couple of months.

Yesterday I rode in some light rain. This morning the powertap was malfunctioning again. This time my power numbers would continually rise even at a constant cadence. I stayed in a low gear, and yet the meter was reporting over 600 watts by the time I stopped. I went through several cycles of pulling the battery and going through calibration process using the powertap mobile app, my Garmin 520, and trainer road. Same behavior with all.

I have again pulled out the battery and electronics cover, and placed a fan on the unit. Will see if this fixes the issue.

A few questions:

1) Has the ingress of moisture corrupted the electronics permanently? I'm concerned about getting accurate readings, even if the clearly incorrect power readings subside by drying the unit out.

2) Assuming there is no permanent damage, how can I keep moisture out of the electronics? I was out yesterday for less than an hour in a very light rain. That causing issues is concerning.

---------------------------------------------------------

"What the mind can conceive and believe, the mind and body can achieve; and those who stay will be champions."
Quote Reply
Re: Official PowerTap Thread [jackattack] [ In reply to ]
Quote | Reply
Hi guys,

Help needed...

Left pedal low (or no) power readings and low cadence, right pedal is working fine.

Just got a brand new battery caps replacement and replaced the batteries too (always lithium) and already tried different vendors. Firmware is up to date (both pedals of course).

I could identify this by using the PowerTap App for iPhone, creating a profile and connecting only the right pedal I`m able to get normal power and cadence. If I connect the left pedal power and cadence drops really low. Only left pedal just low cadence.

Any ideas?

Thank you in advance.
Quote Reply
Re: Official PowerTap Thread [jbartholomew] [ In reply to ]
Quote | Reply
Any plan to release the XDR driver freehub body for the PowerTap G3 and the PowerTap GS hubs in the very near future? I need one or two for SRAM Red AXS eTap 12-speed.
Quote Reply
Re: Official PowerTap Thread [RichardL] [ In reply to ]
Quote | Reply
RichardL wrote:
Any plan to release the XDR driver freehub body for the PowerTap G3 and the PowerTap GS hubs in the very near future? I need one or two for SRAM Red AXS eTap 12-speed.

Would like to know as well

The Powertap site does ave an XD freehub option, so presumably they are aware of the need.
Quote Reply
Re: Official PowerTap Thread [jbartholomew] [ In reply to ]
Quote | Reply
Relatively new Powertap G3 user - laced up in the center of my brand new Rolf Vigor's...

I'm having a small issue with cadence - as I'm pedaling it is reading what appears to be accurate cadence. But when I stop pedaling, the cadence increases, upwards of 140 - but I'm not pedaling. At all. Unless I come to a complete stop, then it reads zero. I think my average cadence is a little high. :) Cadence isn't all that super duper important, but I'd like it to be accurate.

I'm using a Garmin 1000, the Powertap firmware is updated, the battery is fresh. Any suggestions??
Quote Reply
Re: Official PowerTap Thread [fiver49] [ In reply to ]
Quote | Reply
This happens on the road or on the trainer?
Quote Reply
Re: Official PowerTap Thread [rruff] [ In reply to ]
Quote | Reply
On the road.
Quote Reply
Re: Official PowerTap Thread [fiver49] [ In reply to ]
Quote | Reply
Powertap infers cadence from torque pulses, so it will never be that accurate. I've never experienced cadence persisting while coasting though. At any rate if you really want accurate cadence, you should install a cadence sensor. The PT value will never be very good.

Do you have auto-zero turned on? Thinking maybe your offset is wrong and it's reporting torque while coasting, and this value wavers resulting in a cadence.
Quote Reply
Re: Official PowerTap Thread [rruff] [ In reply to ]
Quote | Reply
So, should I have auto zero turned off??
Quote Reply
Re: Official PowerTap Thread [fiver49] [ In reply to ]
Quote | Reply
No. I just wondered what your torque looked like when you were coasting but showing cadence >0.

I never figured out a way to get PT torque data off a Garmin. If you could that might tell you something.

Something just occurred to me. What is your cadence averaging setting (0,3,5,10,30 sec etc)? If it's high it will take awhile for it to drop to zero.
Quote Reply
Re: Official PowerTap Thread [rruff] [ In reply to ]
Quote | Reply
Has anyone seen a power chart like this from their P1 pedals before? The spikes are 4-5 seconds apart and make the readings useless.




I recorded this simultaneously on both my Fenix 5and my Garmin 520, so it's definitely the pedals at fault. I had them serviced about 6 months ago and the new battery caps installed. I'm using fresh lithium batteries and the firmware is up to date. Tried swapping the battery caps over (left to right and vice versa) - no difference.

Any ideas? Or is it time to send them back to for another service?
Quote Reply

Prev Next